MultiOTp with Cisco WCL

I have configured MultiOTP and MultiOTP radius server on windows 2012 and I am trying to authenticate SSID on Cisco WCL using multiOTP but it keep asking for the username and password keep in mind that I have created the username on multistep and tested it with success please feed back with any suggestions


  • Please check the log file on multiOTP, what is written ? Same for Cisco WCL, what says the logfile ?
  • Did you try your username/password on the web interface of multiOTP open source (or using the command line) ? Does it work ?
  • As you have a Windows 2012 server, you could also try the Hyper-V open source virtual appliance available here:
  • I have tried the username on the web interface and it worked and I don't know the location of the log file on Multiotp
  • I have tried the VMware appliance and it give the same output
  • I have tried the username and password on one of our firewalls and it worked perfectly it seems there is an issue bet multiOTP and WLC
  • Hello, The log file is in the multiotp/log/ folder, the filename is multiotp.log. What is the content of the log ? What is the version of the multiOTP open source library you are using ? What is the error message in the Cisco WCL log ? Which radius encryption is used by the Cisco WCL (PAP, CHAP, MS-CHAP, MS-CHAPv2, ...) ? Did you try the commercial appliance multiOTP Pro (the virtual appliance is free and once announced on the Internet, it includes a free lifetime one user licence, which is nice to make tests). You can download the appliance here: You will have an easy access to the log file on the web GUI. Best regards, Andre
  • Is the multiotp prod contains a built in radius server or what
  • sorry I mean the pro version
  • Yes, the Pro version has a built in FreeRADIUS radius server, a full web based configuration interface, ... Regards
  • Online web interface demo is also available;
This discussion has been closed.