Server-Client trouble

I'm having a bit of trouble getting the server-client function set up.
I'm currently trying on two Windows 7 machines with firewalls disabled.

Downloaded, extracted and copied the windows dir to c:\multiotp on both machines.

server is located on
client is located on

On the machine supposed to act as server, I run the webservice_install.bat as administrator and get sent to the GUI on http://localhost:8112 .
In the GUI i add a TOTP user "test", without prefix PIN, to be able to validate function from client later.

on server i also runt the following commands for configuration:

multiotp -config server-secret=secret multiotp -config server-cache-level=1 server-cache-lifetime=15552000 multiotp -debug -display-log -log test <token>
(this is verified correctly "0 *OK: Token accepted")

On the client machine i run the following commands:

multiotp -config server-secret=secret multiotp -config server-cache-level=1 multiotp -config server-timeout=5 multiotp -config server-url= multiotp -debug -display-log -log test <token>

this gives me:
LOG 2017-01-25 12:36:17 debug Debug Debug: *parameter(s) received: -debug -display-log -log test 067782 LOG 2017-01-25 12:36:18 warning System Error: database file C:\multiotp\users\test.db for user test does not exist LOG 2017-01-25 12:36:19 error Client-Server Error: Host answers with the following error code: 70 (ERROR: Server authentication error) 21 *ERROR: User doesn't exist

Comparing the multiotp.ini files i have the same encryption_hash and server_secret values on both machines, so this _should_ work.

Wireshark dump is available upon request.

I'm probably missing something simple, but at this time I'm staring myself blind on this problem. Does anyone have any idea?


  • edited February 2017
    same problems on beta . you can try 4.x version, client-server functionality works properly there
  • The results, achieved with ain't working in newer releases :'(
  • Has anyone else got this to work? I have the same issue (I created an issue at the GitHub page: Failing that, has anyone been able to get it to work with 4.x? When I try a 4.x release (or anything below, actually) I get an error when trying to run multiotp.exe from an elevated command prompt: C:\multiotp-\windows> .\multiotp.exe -config shared-secret=TEST Program 'multiotp.exe' failed to execute: The application has failed to start because its side-by-side configuration is incorrect. Please see the application event log or use the command-line sxstrace.exe tool for more detail At line:1 char:15 + .\multiotp.exe <<<< -config shared-secret=TEST. At line:1 char:1 + <<<< .\multiotp.exe -config shared-secret=TEST + CategoryInfo : ResourceUnavailable: (:) [], ApplicationFailedExecution + FullyQualifiedErrorID : NativeCommandFailed
  • FWIW, I do also have pcaps from Wireshark (available upon request) which may indicate this is something server-side. The server appears to return 200 OK, while not actually sending the client anything, which in turn causes the "User does not exist" error on the client.
  • Hello, the new 5.x edition will be tested with this exact configuration and released next week. Have a nice day
  • Hi, i'm new to multiotp. Can it be that on windows 10, 1607 build 14393 and higher, the client does not work? It seems to have heartbeat at windows 7 but then the backend responds with: user does not exist
  • Tried the version of the client @ windows 10.0.14393 but it does fail at installation (php-7.dll cannot be loaded). Did not verify the backend. Should be reported @ squirrelit?
  • Hello, no, SquirrelIT don't do anything about PHP. What is the exact process, and when does the error appears ? After the installation process, you should have a C:\multiOTP directory, right ? If you open a command line window, you go in C:\multiOTP and you type multiotp.exe, waht is exactly displayed ? PHP dll is embedded in multiotp.exe (multiotp.exe is a "virtual box" including PHP, multiOTP, etc.) Best regards, Andre
  • edited June 2017
    Hi Andre, yes and also from the installer i get the same error after (extracting files, during install) a msg dialog appears: "cannot load library php7.dll". I get the directory on c:\multiotp but without the dll. It is a fresh windows 10 installation. On a windows 7 installation it seems to load the php7.dll. (checked with older version, last week)
  • edited June 2017
    *** I KEEP THIS ANSWER HERE TO HAVE THE FULL STORY, BUT THIS IS NOT THE SOLUTION *** The Visual C++ Redistributable for Visual Studio 2015 x86 or x64 should be integrated, but it could be possible that there is a problem here. Try to download separately the redistributable : and keep us in touch. Regards Andre
  • Hello, We were able to reproduce the problem and we found the issue, the new version is available on Regards and thanks a lot for your valuable feedback. Any comments welcome. Andre
  • Hi Andre, succefully installed the client. Unfortunately the " user does not exist" remains. I have an appliance (upgraded with the seperate PHP-files). Also a windows service installation gives the same " user does not exist". Is there something i can test by CLI?
  • edited June 2017
    I guess i do not know where to start with the appliance. @ appliance: LOG 2017-06-03 13:50:37 debug Client-Server Warning: Host on port 8112 not reached before a timeout of 5 seconds. LOG 2017-06-03 13:50:37 debug Client-Server Warning: Host on port 8112 not reached before a timeout of 5 seconds. LOG 2017-06-03 13:50:37 debug Client-Server Warning: Host on port 8112 not reached before a timeout of 5 seconds. LOG 2017-06-03 13:50:37 debug Client-Server Warning: Host on port 8112 not reached before a timeout of 5 seconds. LOG 2017-06-03 13:50:37 notice (user administrator) User OK: User administrator successfully logged in with TOTP token 0 *OK: Token accepted
  • on the web-interface it seems to work
  • wait, whenever i use the windows-web-service, it just works with the settings provided in the beginning of this post.
  • feels like the VM is not working like it should...
  • Hello, the new multiOTP open source virtual appliance in VMware format is available for download: Thanks in advance for your feedback Regards, Andre
  • I reported the original trouble. Not having tested for quite some time, I tried it with multiOTP 2018-03-20 and now it works great! Configured it to sync with an Active Directory server as well, and not a problem in sight so far :smile: Great work!
  • Hello, Thanks a lot for your feedback. Regards. Andre
This discussion has been closed.