LDAP sync with eDirectory

Hi there. I hoping someone can help with this sync problem I'm having. I'm connecting to eDirectory, which originally started with Novell, but is now with Micro Focus. We use several ldap clients which interact ok, but I'm having an error with multiotp when I try to do a users-sync or users-list. In looking at a wireshark trace, I can see a successful bind, but then an error "invalidDNSyntax". Multiotp reports the error as: warning LDAP Error: FATAL: AD/LDAP bind failed. The BaseDN is not accepted I'm using here since I need to start the search from the very top of the tree. I've also tried more specific values, like ou=accounting,o=alberta. Regardless of what I tried, I got the same error. Looking further at the wireshark trace, I see that there's a dn value of 'test-connection' that is being sent. I wonder if that is what may be causing this error since that object does not exist in the directory. Has anybody seen this kind of problem before or maybe some thoughts on where I should focus my efforts? Thanks!!

Comments

  • Hello, we are not able to test eDirectory since there is no free version. Are you able to create a test infrastructure and to open it for us in order to make some tests ? Regards
  • I will set something up in the next week or 2. Thanks so much.
Sign In or Register to comment.